Symptom
Sie haben ein Material oder ein Serviceprodukt ganz oder teilweise eingerichtet. Jetzt möchten Sie das Material oder das Serviceprodukt löschen.
Reproducing the Issue
- Rufen Sie das Work Center Produktdaten auf.
- Wählen Sie die Sicht Materialien oder Services.
- Wählen Sie ein beliebiges Material oder Serviceprodukt aus.
Es gibt keine Option zum Löschen des Produkts.
Cause
Leider steht derzeit keine Funktion zum Löschen von Stammdaten nach der Einrichtung bzw. nach dem Sichern zur Verfügung. Deshalb können Sie kein vollständig oder teilweise angelegtes Material oder Serviceprodukt löschen. Das Löschen solcher Daten aus der Datenbank ist auch deshalb nicht möglich, weil damit eine Vielzahl an Folgeaktivitäten erforderlich wäre und Dateninkonsistenzen, z.B. in Business Intelligence-Berichten, entstehen könnten.
Resolution
Als Behelfslösung können Sie das nicht mehr benötigte Produkt auf den Status "Gesperrt" setzen, wodurch es in keinem Geschäftsprozess mehr verwendet werden kann.
Schritte zum Sperren eines Produkts:
- Rufen Sie das Work Center Produktdaten auf.
- Wählen Sie die Untersicht Nach Materialien oder die Untersicht Nach Services.
- Markieren Sie ein Material oder einen Service.
- Wählen Sie Alles anzeigen.
- Wechseln Sie zur entsprechenden Geschäftsbereichsregisterkarte (Registerkarte Einkauf oder Registerkarte Verkauf).
- Ändern Sie den Status von Aktiv in Gesperrt um.
Material:
Sobald ein Material für Einkauf, Logistik, Planung, Verfügbarkeitsprüfung, Verkauf und Bewertung aktiviert ist, ist das Sperren des Materials nur für den Einkauf und für den Verkauf zulässig. Der Status für Logistik, Planung, Verfügbarkeitsprüfung und Bewertung darf nicht auf
"Gesperrt" gesetzt werden.
Dieses Verhalten ist damit begründet, dass bei Verwendung des Materials in der Logistik, Planung, Verfügbarkeitsprüfung und Bewertung das Festlegen des Status "Gesperrt" im Ergebnis zu Inkonsistenzen in den Geschäftsvorfallbelegen führen würde, in denen dieses Material verwendet wird. Daher ist es allgemein nicht erlaubt, den Status des Materials für Logistik, Planung, Verfügbarkeitsprüfung und Bewertung auf "Gesperrt" zu setzen.
Sobald Sie das Material aber für den Einkauf und den Verkauf sperren, wird dieses Material niemals mehr für Einkauf und Verkauf verwendet werden. Dies bedeutet, dass für dieses Material keine neuen Einträge im System angelegt werden können. Allerdings bleibt Material, dass sich bereits in der Logistik (oder in einem beliebigen SCM-Prozess) befindet, davon unberührt.
Anmerkung: Falls das Material den Status In Vorbereitung aufweist, müssen Sie den Status auf Aktiv setzen. Sie können danach den Status in Gesperrt umändern.
Service:
Sobald ein Service für Einkauf, Verkauf und Bewertung aktiviert ist, ist das Sperren des Materials nur für den Einkauf und für den Verkauf zulässig. Es ist nicht zulässig, den Status der Bewertung auf "Gesperrt" zu setzen.
Dieses Verhalten ist damit begründet, dass bei Verwendung des Service in der Bewertung das Festlegen des Status "Gesperrt" im Ergebnis zu Inkonsistenzen in den Geschäftsvorfallbelegen führen würde, in denen dieser Service verwendet wird. Daher ist es allgemein nicht erlaubt, den Status des Service für die Bewertung auf "Gesperrt" zu setzen.
Sobald Sie den Service aber für den Einkauf und den Verkauf sperren, wird dieser Service niemals mehr für Einkauf und Verkauf verwendet werden. Dies bedeutet, dass für diesen Service keine neuen Einträge im System angelegt werden können.
Anmerkung: Falls der Service den Status In Vorbereitung aufweist, müssen Sie den Status auf Aktiv setzen. Sie können danach den Status in Gesperrt umändern.
Keywords
KBA , SRD-MD-PRD-PRD , Product , Product Enhancement