Symptom
Wenn Sie den Versuch einer Massenänderung für Kundendaten ausgewählter Kunden unternehmen, gibt das System die nachstehende Fehlermeldung aus:
Verkaufsdaten: Instanz mit gleichem Schlüssel bereits vorhanden
Anmerkung: Sie nehmen gerade eine Zuordnung von Verkaufsorganisation/Vertriebsweg zu den Kunden mithilfe einer Massenänderung vor. Diese Zuordnung kann mittels der Option Aus Arbeitsvorrat entfernen in Schritt 1 ausgeführt werden.
Reproducing the Issue
- Rufen Sie das Work Center Kundenmanagement auf.
- Wählen Sie den unter Allgemeine Aufgaben angezeigten Punkt Massenänderung für Kundendaten.
- Geben Sie in das Feld "Suchen" einen Asterisk (*) ein, damit alle Kunden angezeigt werden.
- Wählen Sie Zum Arbeitsvorrat hinzufügen -> Alle Kunden, und wählen Sie dann Weiter.
- Wählen Sie bei Schritt 2 (Kunden ändern) aus der Aufklappliste des Feldes "Anzeigen" die Option Verkaufsdaten aus.
- Tragen Sie in die für die Massenänderung hervorgehobene Zeile die Verkaufsorganisation und den Vertriebsweg ein.
- Wählen Sie Massenänderung anwenden -> Alle Kunden.
- Wählen Sie Fertigstellen.
Cause
Das Problem wird dadurch verursacht, dass einige Kunden vorhanden sind, die bereits über eine zugeordnete Verkaufsorganisation und einen zugewiesenen Vertriebsweg verfügen.
Resolution
Das Problem ist bekannt und wird im nächstfolgenden SAP-Business-ByDesign-Release behoben sein.
Behelfsweise können Sie eine Massenänderung nur für die Kunden vornehmen, denen noch keine Verkaufsorganisation und kein Vertriebsweg zugeordnet ist.
Keywords
KBA , AP-BP-BPT , Business Partner Template , Product Enhancement