Symptom
Wenn Sie versuchen, einen ausgetretenen Mitarbeiter neu einzustellen, zeigt das System die folgenden Fehlermeldungen an:
Arbeitsvertrag für Mitarbeiter im eingegebenen Zeitraum vorhanden
Wiedereinstellung fehlgeschlagen
Reproducing the Issue
- Rufen Sie das Work Center Personalverwaltung auf.
- Wählen Sie die Sicht Typische Aufgaben.
- Wählen Sie den Link Mitarbeiter wiedereinstellen.
- Wählen Sie über die Eingabehilfe einen ausgetretenen Mitarbeiter aus.
- Versehen Sie alle Mussfelder mit einem Eintrag.
- Wählen Sie Sichern.
Cause
Das Problem tritt auf, weil das ausgewählte Eintrittsdatum entweder gleich dem letzten Austrittsdatum ist oder zeitlich vor diesem liegt. Dies ist aus logischer Sicht unmöglich.
Resolution
Das eingegebene Wiedereinstellungsdatum muss nach dem letzten Austrittsdatum des Mitarbeiters liegen. Korrigieren Sie das Wiedereinstellungsdatum, und führen Sie den Wiedereinstellungsvorgang nochmals aus.
Falls der Mitarbeiter bei Ersteinstellung mit einem falschen Arbeitsvertrag oder falscher organisatorischer Zuordnung eingestellt wurde, und Sie dies berichtigen möchten, empfiehlt SAP Ihnen die folgenden Optionen:
- Sie können die Wiedereinstellung am Tag nach dem Austrittsdatum in Kraft setzen. Somit können Sie einen neuen Arbeitsvertrag dem gleichen Mitarbeiter zuordnen.
- Die zweite Option bestünde darin, eine neue Mitarbeiterdatei mit einer neuen Personalnummer und einem neuen Arbeitsvertrag anzulegen, die zum gleichen Datum in Kraft treten.
Keywords
KBA , SRD-HR-PAD , Personnel Administration , How To