Symptom
You may get the below error message when creating a new leave request by self services:
Error Message: No quota available
Reproducing the Issue
- Go to the work center Home
- Select the view Self-Services
- Select the link New Leave Request under the section Time
- Follow the guided procedure to request a leave
- Select the button Save, the error no quota available occurs
Cause
If you are requesting a new leave for the first time and if you receive 'no quota available' error, it could be the case that the configuration of the time profile of the employee is not completed.
In particular the error may be caused by missing Time Account Accrual Rule which results in no initial entitlement and no balance for the time account. Therefore you are not able to request any leave, as no deduction is possible for the time account.
Resolution
In order to solve the issue it is necessary to assign a Time Account Accrual Rule to the employee:
- Go to the work center Time Administration
- Select the view Employees
- Select the relevant employee in the list and select the button Edit
- Select the tab Time Profile
- Select the below sub-tab Time Accounts rule
- Assign the preferred Time Account Rule to the time account
- Select the button Save
Keywords
KBA , SRD-CC , Cross Components , Product Enhancement