SAP Knowledge Base Article - Public

1154329 - Service Agent Cannot Create Leave Requests in Self Services

Symptom

The link 'New Leave Request' does not exist in the view 'Self-Services' so that the service agent cannot create a leave request by employee self-service.

Reproducing the Issue

  1. Go to the work center 'Home'.
  2. Select the view 'Self Services' and the option 'Self Services Overview'.
  3. The link 'New Leave Request' does not exist.

Cause

The reason that the user does not have the option of creating leave request is because he/she is a service agent (external employee).

Resolution

The system is working as designed.

If a user is external employee (service agent), it is not possible for him/her to create leave request by self service.

See Also

If the user is internal employee but still he/she is not able to view the link 'New Leave Request' in Self Services, you can refer to the case document 1234548 - The Link 'New Leave Request' Not Available in the Employee Self-Services for resolution.

Keywords

KBA , SRD-FIN-CLM , Cash and Liquity Managment , Product Enhancement

Product

SAP BUSINESS BYDESIGN 1708