SAP Knowledge Base Article - Public

1197347 - Error: "Invalid Argument provided. Details: Java Server startup failure.." when connecting to Salesforce.com from Crystal Reports XI

Symptom

When attempting to connect to a valid Salesforce.com professional account from Crystal Reports XI, the following error message appears:
"Invalid Argument provided. Details: Java Server startup failure. Please verify the PATH (JDK), CLASSPATH and IORFileLocation properties in the CRConfig.xml file. In addition, please verify you are using JDK 1.4."

Cause

The error message is caused by an older version of the Crystal Reports Salesforce.com driver not connecting with professional accounts. Other error messages may include "Failed to establish a connection."

Resolution

To resolve this issue, follow these steps:
  1. Close Crystal Reports.
  2. Verify that you have at least version 1.4 of the Java Runtime Environment (JRE) by opening Internet Explorer and clicking on Tools > Sun Java Console. If the Java Console Message says "Java Plug-in 1.4.0_00. Using JRE version 1.4.0_00 Java HotSpot(TM) Client VM" or higher you are using the correct version of the JRE. 
  3. Go to the appropriate directory for your version of CRXI and back up the CRConfig.xml file, then delete it. If you are using CRXI R1, the directory will be C:\Program Files\Common Files\Business Objects\3.0\Java, and if you are using CRXI R2 the directory will be C:\Program Files\Business Objects\Common\3.5\Java.
  4. Reopen Crystal Reports; CR will recreate the CRConfig.xml file when you reopen the program. When the "Installing" message box disappears, close CR.
  5. Search for sfdc.msi on your computer. This is the installation file for the Salesforce.com driver. When you double-click this installation file, you will be asked whether you want to repair or uninstall the Salesforce.com driver. Uninstall the driver. Delete all existing sfdc.zip files or unzipped sfdc files and directories including the sfdc.msi file you just executed.
  6. Download the latest version of the Crystal Reports Salesforce.com driver, available from http://ftp1.businessobjects.com/outgoing/sales/ondemand/sfdc_driver30.zip Unzip the zip file to a convenient temporary location that you will be able to find; for example, your desktop.
  7. Run the new sfdc.msi installation file; the installation file will install the latest version of the Salesforce.com drivers.
You should now be able to connect with Salesforce.com from CRXI using a valid username and password.

Keywords

Salesforce, Java Error, JRE , 3287379 , KBA , BI-BIP , Business intelligence platform , Bug Filed

Product

Crystal Reports Server XI R2 ; Crystal Reports Server XI R2, OEM edition ; SAP Crystal Reports XI ; SAP Crystal Reports XI R2 ; SAP Crystal Server XI