SAP Knowledge Base Article - Public

1198092 - Error: "Error: Failed to retrieve data from database" when adding a parameter with no value to a report

Symptom

  • Parameter that has no value is added to a report.
  • Report connects to the database using a Lawson OLEDB Provider.
  • Error: "Error: Failed to retrieve data from database."

Cause

The issue has been identified and tracked under ID ADAPT00601419. It affects the following:

  • Crystal Reports XI
  • Crystal Reports 10

Resolution

Hot Fixes or Service Packs address this issue as indicated below. With the update(s), this problem is resolved.3-XXX_RESOLUTION_TEXT_XXX

Unless indicated otherwise, Critical Hot Fix updates from the FTP site have only been tested with English versions of our products.


CAUTION

Hot Fixes and Service Packs are not designed for OEM versions. Do not apply these updates if you are using an OEM version. To determine if you are using an OEM version, refer to the OEM Product Warning.



Crystal Reports XI

The latest update for this issue is available on the Downloads area of our web site.

This issue is addressed in the following components (and later versions):

  • crdb_ado.dll, version 11.0.0.2185, dated 26/07/2006 (commonXIwin_chf.zip)

 


Crystal Reports 10

The latest update for this issue is available on the Downloads area of our web site.

This issue is addressed in the following components (and later versions):

  • crdb_ado.dll, version 10.0.5.668, dated 26/07/2006 (dbex10win_en.zip)

 


Monthly Hot Fixes and Service Packs

To determine if this issue is also addressed in a Monthly Hot Fix or Service Pack for your product, search the readme file for the Track ID number (that is, ADAPTXXXXXXXX) in the latest Monthly Hot Fix or Service Pack.

Monthly Hot Fixes readmes and Service Pack readmes are available in the Downloads area of our web site.


NOTE

Issues addressed on one operating system platform at the Weekly Hot Fix level may be addressed later on multiple operating system platforms (if applicable) at the Monthly Hot Fix and Service Packs level. For example, an issue only resolved on the Windows platform in a Weekly Hot Fix may be resolved later on UNIX platforms such as IBM AIX and Sun Solaris in future Monthly Hot Fixes or Service Packs for these platforms.

To determine if these issues are resolved in a Monthly Hot Fix or Service Pack on another platform, search for the Track ID number in the readme at the locations indicated above.

See Also

For more information on the issues addressed in the Hot Fix or Service Pack, view the readme PDF or text file included in the ZIP or TAR file.

For more information on the different update types, refer to our Hot Fix and Service Pack FAQ.

Keywords

CHF , 285334 , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Bug Filed

Product

SAP Crystal Reports 10.0 ; SAP Crystal Reports XI ; SAP Crystal Reports XI R2