SAP Knowledge Base Article - Public

1201724 - Error received when exporting reports results to ODBC - MS Access.

Symptom

Two reports created in Crystal Reports 8.5 are opened in Crystal Reports XI. Both the reports are then exported to the  ODBC-MS Access. One report is exported fine but while exporting the other report the following error occurs: "Failed to export the report. There is no valid database for this report. ODBC export cancelled."

Cause

Two reports created in Crystal Reports 8.5 are opened in Crystal Reports XI. Both the reports are then exported to the  ODBC-MS Access. One report is exported fine but while exporting the other report the following error occurs: "Failed to export the report. There is no valid database for this report. ODBC export cancelled."

Resolution

  1. Open both the reports in Crystal Reports XI.
  2. Go to File|Export|Export Report.
  3. Select ODBC.
  4. Click OK.
  5. Select a MS ACCESS ODBC DSN from the list and click OK.
  6. After following the steps 2 to 5 for the first report it gets exported. But with the second report the error arises: "Unable to export".
  7. After looking at the second report it was found that there was an empty text box n the Page Footer of the non working report. Once that text was removed from the report and export to ODBC-MS Access wa s tried the report got exported without any errors.

 

So,in order to export a XI report to ODBC-MS Access there should not be any empty text box in the report. In case of version 8.5 it was permissible whereas in case of XI it is not allowed.


Keywords

export, ODBC Export, MS Access , 5731103 , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Bug Filed

Product

SAP Crystal Reports XI ; SAP Crystal Reports XI R2