Symptom
The API functions that handle a shared secret need to be restructure to enhance the process.
The API functions are as follows:
ITrustedPrincipal trustedPrincipal = sessionMgr.createTrustedPrincipal(userid,cms). The file TrustedPrincipal.conf saves the shared secret.
Cause
The issue has been identified and tracked under ID ADAPT00583709. It affects BusinessObjects Enterprise XI Release 2 for AIX.
Resolution
Hot Fixes or Service Packs address this issue as indicated below. With the update(s), the API has been updated with the following functions to handle a shared secret:
ITrustedPrincipal trustedPrincipal =sessionMgr.createTrustedPrincipal(userid,cms,sharedsecret);
The function TrustedPrincipal.conf is no longer needed.
In the desktoplaunch\WEB-INF\web.xml, the userID on the parameter can be retrieved with trusted.auth.user.retrieval configured as follows:
- Set to "IIS_HEADER" for IIS-added header.
- Set to "HTTP_HEADER" for HTTP header.
- Set to "QUERY_STRING" for URL query string.
- Set to "COOKIE" for cookie.
- Set to "WEB_SESSION" for web session.
- Set to "USER_PRINCIPAL" for user principal.
- Reset to "empty" to disable trusted authentication.
Also, set the variable name in Header/URL parameter/Cookie/Session to retrieve the username on the parameter trusted.auth.user.param. There is no need to set the variable for IIS_HEADER or USER_PRINCIPAL.
Set the session variable name to retrieve the shared secret on the parameter trusted.auth.shared.secret.
Unless indicated otherwise, Critical Hot Fix updates from the FTP site have only been tested with English versions of our products.
CAUTION | Hot Fixes and Service Packs are not designed for OEM versions. Do not apply these updates if you are using an OEM version. To determine if you are using an OEM version, refer to the OEM Product Warning. |
BusinessObjects XI Release 2 for AIX
The latest update for this issue is available on the Downloads area of our web site.
This issue is addressed in the following components (and later versions):
- 5-XXX_FILE_XXX
Monthly Hot Fixes and Service Packs
To determine if this issue is also addressed in a Monthly Hot Fix or Service Pack for your product, search the readme file for the Track ID number (that is, ADAPTXXXXXXXX) in the latest Monthly Hot Fix or Service Pack.
Monthly Hot Fixes readmes and Service Pack readmes are available in the Downloads area of our web site.
NOTE | Issues addressed on one operating system platform at the Weekly Hot Fix level may be addressed later on multiple operating system platforms (if applicable) at the Monthly Hot Fix and Service Packs level. For example, an issue only resolved on the Windows platform in a Weekly Hot Fix may be resolved later on UNIX platforms such as IBM AIX and Sun Solaris in future Monthly Hot Fixes or Service Packs for these platforms. To determine if these issues are resolved in a Monthly Hot Fix or Service Pack on another platform, search for the Track ID number in the readme at the locations indicated above. |
See Also
For more information on the issues addressed in the Hot Fix or Service Pack, view the readme PDF or text file included in the ZIP or TAR file.
For more information on the different update types, refer to our Hot Fix and Service Pack FAQ.
Keywords
CHF , 7717126 , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Bug Filed