SAP Knowledge Base Article - Public

1212476 - Access to system ODBC data sources restricted after installing Crystal Reports 8

Symptom

  • Unable to access some ODBC DSN.
  • In Crystal Reports, it is not possible to use some of the System ODBC data sources.
  • Installing Crystal Reports 8 on MS Windows may prevent connections to system ODBC data sources.
  • This occurs on new ODBC data source names (DSNs) accessed under a user account without administrator privileges.

Environment

  • Crystal Reports 8

Cause

  • The Crystal Reports 8 installation made changes to registry permissions. Uninstalling Crystal Reports 8 does not undo the changes.
  • The issue does not exist with Crystal Reports 8.5

Resolution

  • To resolve the rights issue:
         
    1. Restore the MS Windows registry permissions back to their default settings by downloading and running the utility: scr8_webregfix.exe
             
    2. If you are connecting to a database using ODBC, download the updated Crystal Reports 8 ODBC database driver p2sodbc8.zip available on the Downloads area of our web site.
             
      Note: This Crystal Reports ODBC driver (version 8.0.0.85) allows connections to be made to a ODBC data source with default registry permissions settings. Earlier versions of this driver cannot connect to an ODBC data source with default registry permissions.

See Also

  • Why does this behavior occur if a user without administrator privileges attempts to connect using a System ODBC DSN?
     
    ODBC System Data Source (DSN) information is stored in the Microsoft Windows registry at this subkey and its lower level subkeys:
      
        HKEY_LOCAL_MACHINE\Software\ODBC\odbc.ini
       
    The Microsoft Windows NT default permissions for these subkeys are (following a format of <Group> -- <Permission>):
     
        CREATOR OWNER -- Full Control
       <Local Machine>\Administrators -- Full Control
        Everyone -- Special Access
        SYSTEM -- Full Control
       
  • When Crystal Reports 8 is installed, permissions for the above registry subkey and its lower level subkeys are modified. The Everyone group's permissions are broadened from Special Access to Full Control. When you create a new System DSN (with subkeys) after Crystal Reports is installed, it neither inherits the Windows NT default permissions settings, nor sets the new permissions set by the Crystal Reports 8 installation. Instead, the new DSN's subkeys receive permissions for only these two user groups:
      
        <Local Machine>\Administrators -- Full Control
         SYSTEM -- Full Control
       
  • No permissions are set up for the 'Everyone' group. Permissions are only set up for the Administrator and System accounts; therefore only users with these privileges can access the DSN. The scr8_webregfix.exe update resets registry permissions for all affected subkeys back to the Windows NT default. Permissions are now set for the Everyone and CREATOR OWNER groups:
       
        CREATOR OWNER -- Full Control
        <Local Machine>\Administrators -- Full Control
        Everyone -- Special Access
        SYSTEM -- Full Control
        
  • The P2sodbc.dll that ships with the original release of Crystal Reports (version 8.0.0.84) cannot connect to an ODBC System DSN using Windows NT default registry permissions. Version 8.0.0.84 requires that the Everyone group is set to Full Control and cannot connect using a special access (default) permission level. The updated P2sodbc.dll, version 8.0.0.85, enables you to connect to a System ODBC DSNs using default permissions.

Keywords

JDO ADMINISTRATOR USER PERMISSIONS RIGHTS 599 20599 ODBC P2SODBC.DLL Seagate Crystal Reports Accessing ODBC data sources , c2007581 , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Bug Filed

Product

SAP Crystal Reports 8.0

Attachments

scr8_webregfix.exe