SAP Knowledge Base Article - Public

1216206 - The Field Explorer does not appear in the Crystal Reports Designer

Symptom

  • In Crystal Reports, when you click the 'View' menu then select 'Field Explorer' the Field Explorer does not appear.

Environment

  • SAP Crystal Reports 2011
  • SAP Crystal Reports 2013
  • SAP Crystal Reports 2016

Cause

  • This occurs because the value for the registry sub key that controls the docking of the Field Explorer has changed. Usually happens after changing multiple monitors configuration to a single monitor, like taking laptop  of docking station.

Resolution

  • The registry key value must be changed back to the original value for the Field Explorer to appear.

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WARNING:

Using the Registry Editor can cause serious problems that may require reinstalling the operating system. SAP is not responsible for any problems resulting from using the Windows Registry Editor. Use the Registry Editor at your own risk. It is recommended that you back up the registry before you edit it.

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  1. On the 'Start' menu, click 'Run'.
  2. Type 'regedit' in the 'Open' combo box. Click 'OK'.
  3. Browse to the following registry sub key: HKEY_CURRENT_USER\SOFTWARE\SAP BusinessObjects\Suite XI 4.0\Crystal Reports\Docking2\Field Explorer
  4. Right-click the 'Float Rec' string value, and then click 'Modify'. If the field is not available, create one. 
  5. In the 'Value data' text box, enter: 0,38,200,227
  6. Click 'OK'. Close the Registry Editor.
  7. Close Crystal Reports.

See Also

2055685 - The Field Explorer is missing in the Crystal Reports Designer

Keywords

FIELD EXPLORER GONE NOT VISIBLE GUI UI USER INTERFACE VIEW Crystal Reports The Crystal Reports user interface Field Explorer , c2013534 , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem

Product

SAP Crystal Reports 2011, feature pack 03 ; SAP Crystal Reports 2013 ; SAP Crystal Reports 9.0