Symptom
In Crystal Reports XI, the 'Universe' data source is missing from the 'Create New Connection' and from the 'Database Expert'. Therefore, you are unable to connect to a Universe.
Cause
This known issue has been assigned Track ID ADAPT00373475.
Resolution
Hot Fixes or Service Packs address this issue as indicated below. With the update(s), dependency files for the file used to connect to a Universe (crdb_universe.dll) are added to your computer. A registry sub key is also added. The files added are:
btuc240.dll, version 2.4.4.0, dated 11/28/2001
cpcoll.dll, version 11.0.0.284, dated 12/8/2004
cpi18n.dll, version 11.0.0.284, dated 12/8/2004
cplib.dll, version 11.0.0.284, dated 12/8/2004
thread-vc-mt.dll, dated 12/5/2003
The new registry sub key is:
HKEY_LOCAL_MACHINE\SOFTWARE\Business Objects\Suite 11.0\default\BINDIR
Unless indicated otherwise, Weekly Hot Fix updates from the FTP site have only been tested with English versions of our products.
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CAUTION:
Hot Fixes and Service Packs are not designed for OEM versions. Do not apply these updates if you are using an OEM version. To determine if you are using an OEM version, refer to the OEM Product Warning.
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Crystal Reports XI
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For Crystal Reports XI, the latest update for this issue is available on the Downloads area of our website.
This issue is addressed in the following components (and later versions):
- btuc240.dll, version 2.4.4.0, dated 11/28/2001
- cpcoll.dll, version 11.0.0.284, dated 12/8/2004
- cpi18n.dll, version 11.0.0.284, dated 12/8/2004
- cplib.dll, version 11.0.0.284, dated 12/8/2004
- thread-vc-mt.dll, dated 12/5/2003
Monthly Hot Fixes and Service Packs
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To determine if this issue is also addressed in a Monthly Hot Fix or Service Pack for your Crystal product, search the readme file for the Track ID number (that is, ADAPTXXXXXXXX) in the latest Monthly Hot Fix or Service Pack.
Monthly Hot Fix and Service Pack readmes for Crystal products are found on the Downloads area of our website.
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NOTE:
Issues addressed on one operating system platform at the Weekly Hot Fix level may be addressed later on multiple operating system platforms (if applicable) at the Monthly Hot Fix and Service Packs level. For example, an issue only resolved on the Windows platform in a Weekly Hot Fix may be resolved later on UNIX platforms such as IBM AIX and Sun Solaris in future Monthly Hot Fixes or Service Packs for these platforms.
To determine if these issues are resolved in a Monthly Hot Fix or Service Pack on another platform, search for the Track ID number in the readme at the locations indicated above.
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See Also
For more information on the issues addressed in the Hot Fix or Service Pack, view the readme PDF or text file included in the ZIP or TAR file.
For more information on the different update types, refer to our Hot Fix and Service Pack FAQ.
Keywords
CR WHF 373475 CONNECT TO UNIVERSE DEPENDENCY Crystal Reports Connect to a universe Cannot connect Missing datasource , c2017168 , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Bug Filed