SAP Knowledge Base Article - Public

1218675 - "No items found" when attempting to report off Outlook/Exchange in Crystal Reports

Symptom

  • No Items found.
  • Unable to report off Exchange server in Crystal Reports.
  • When attempting to report off a Microsoft Exchange Server public folder in Crystal Reports, it displays: "No items found"

Environment

  • SAP Crystal Reports 2013
  • SAP Crystal Reports 2016
  • SAP Crystal Reports 2020
       
  • MS Outlook 2013
  • MS Outlook 2016 

Reproducing the Issue

  1. In Crystal Reports, create a new report.
  2. In Database Expert, under "New Connection", double click on "Outlook/Exchange"
  3. Select a MS Exchange public folder.
  4. Back to the Database Expert, it displays: "No items found"

Cause

  • This behavior occurs when the 'Use Cached Exchange Mode' checkbox is checked in Microsoft Outlook.
        
  • When MS Outlook have the option 'Use Cached Exchange Mode' checked, it stores email messages in a file on your computer, instead of on the Exchange Server. Since the MAPI driver cannot report off a privately stored file, the 'Use Cached Exchange Mode' checkbox must be clear in order to use the Exchange/MAPI driver.

Resolution

  • In order to report successfully from public folders with MS Outlook, uncheck the MS Outlook option: "Use Cached Exchange Mode"
      
    • In MS Outlook 2013:

      1. Under the menu "Tools", click "E-mail Accounts"
      2. Click "View or change existing e-mail accounts" option button and then click "Next"
      3. Select the email account, and then click "Change"
      4. Uncheck the option: "Use Cached Exchange Mode",  then click "Next"
      5. Click "Finish"
      6. Quit MS Outlkook, and restart MS Outlook.

             
    • In MS Outlook 2016:

      1. In MS Outlook 2016, under "File"
      2. Select: "Account Settings > Account Settings..."
      3. In "Account Settings", under the tab "Email", select an Exchange account from the list and click: "Change"
      4. In "Chnage Account", click on the button "More Settings..."
      5. In "Microsoft Exchange" window, under, the tab "Advanced", uncheck the option "Cached Exchange Mode", and select OK.
      6. Back to "Change Account", click "Next"
      7. Then click "Finish"
      8. Back to "Account Settings", click "Close"
      9. Quit MS Outlkook, and restart MS Outlook.

Keywords

EXCHANGE OUTLOOK 2003 MAPI PUBLIC FOLDERS NO ITEMS FOUND Crystal Reports Outlook/Exchange Exchange Folders , c2017791 , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem

Product

SAP Crystal Reports 2013 ; SAP Crystal Reports 2016 ; SAP Crystal Reports 2020