SAP Knowledge Base Article - Public

1218997 - Cannot re-open a report in Microsoft Outlook 2003 Business Contact Manager

Symptom

A Microsoft Visual Studio .NET application uses Crystal Reports for Visual Studio .NET 2003 as the reporting development tool.

When you open a report through Microsoft Outlook 2003 Business Contact Manager it opens successfully. If you then close it and attempt to re-open the report it does not reopen if .NET Framework 2.0 is installed on the computer.

Cause

The issue has been identified and tracked under ID ADAPT00416507.

Resolution

Hot Fixes or Service Packs address this issue as indicated below. With the update(s), the problem was that when PEGetNthTableTypeN was called the second time, the memory just beyond the PETableTypeW structure used to get corrupted. With the fixed CPRE, this doesn't happen.

Unless indicated otherwise, Weekly Hot Fix updates from the FTP site have only been tested with English versions of our products.

====================

CAUTION:

Hot Fixes and Service Packs are not designed for OEM versions. Do not apply these updates if you are using an OEM version. To determine if you are using an OEM version, refer to the OEM Product Warning.

====================

Crystal Reports for Visual Studio .NET 2003

-------------------------------------------------

For Crystal Reports for Visual Studio .NET 2003, the latest update for this issue is available on the Downloads area of our web site.

This issue is addressed in the following components (and later versions):

  • crpe32.dll, version 9.1.2.1111, dated 5/23/2005 (crnet11win_en.zip)

 

Monthly Hot Fixes and Service Packs

------------------------------------------

To determine if this issue is also addressed in a Monthly Hot Fix or Service Pack for your product, search the readme file for the Track ID number (that is, ADAPTXXXXXXXX) in the latest Monthly Hot Fix or Service Pack.

Monthly Hot Fixes readmes and Service Pack readmes are available in the Downloads area of our web site.

====================

NOTE:

Issues addressed on one operating system platform at the Weekly Hot Fix level may be addressed later on multiple operating system platforms (if applicable) at the Monthly Hot Fix and Service Packs level. For example, an issue only resolved on the Windows platform in a Weekly Hot Fix may be resolved later on UNIX platforms such as IBM AIX and Sun Solaris in future Monthly Hot Fixes or Service Packs for these platforms.

To determine if these issues are resolved in a Monthly Hot Fix or Service Pack on another platform, search for the Track ID number in the readme at the locations indicated above.

See Also

For more information on the issues addressed in the Hot Fix or Service Pack, view the readme PDF or text file included in the ZIP or TAR file.

For more information on the different update types, refer to our Hot Fix and Service Pack FAQ.

Keywords

CR WHF 416507 MS OUTLOOK BUSINESS CONTACT MANAGER BCM OPEN RE-OPEN Crystal Reports for Visual Studio Re-opening a report Business Contact Manager (BCM) , c2017743 , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Bug Filed

Product

SAP Crystal Reports, version for Visual Studio .NET 2005 ; SAP Crystal Reports, version for Visual Studio .NET 2008 ; SAP Crystal Reports, version for Visual Studio .NET 9.1