Symptom
When you click 'Verify the Database' on a report created in Crystal Reports version 8.5 that contains a subreport based on a stored procedure with parameters, the following error message appears:
"Prompting failed with the following error message: Error source : Error code 0x8000FFFF".
The Same error message may also be displayed when viewing the report on demand with Crystal Reports Server XI R2 or Business Objects Enterprise XI R2.
The cause of the problem is that when a stored procedure with parameters is used in a subreport, the prompts are identified, but the prompt information fails to be collected and passed to the prompting engine.
Cause
The cause of the problem is that when a stored procedure with parameters is used in a subreport, the prompts are identified, but the prompt information fails to be collected and passed to the prompting engine.
The issue has been identified and tracked under ID ADAPT00567597.
Resolution
Hot Fixes or Service Packs address this issue as indicated below. With the update(s), this problem is resolved.
Unless indicated otherwise, Critical Hot Fix updates from the FTP site have only been tested with English versions of our products.
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CAUTION:
Hot Fixes and Service Packs are not designed for OEM versions. Do not apply these updates if you are using an OEM version. To determine if you are using an OEM version, refer to the OEM Product Warning.
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BusinessObjects Enterprise XI Release 2 for Windows
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For BusinessObjects Enterprise XI Release 2 for Windows, the latest update for this issue is available on the Downloads area of our web site.
This issue is addressed in the following components (and later versions):
- crpe32.dll, version 11.5.4.450, dated 3/29/2006 (boXIr2win_chf.zip)
- crw32.exe, version 11.5.4.450, dated 3/29/2006 (boXIr2win_chf.zip)
BusinessObjects Enterprise XI for Windows
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For BusinessObjects Enterprise XI for Windows, the latest update for this issue is available on the Downloads area of our web site.
This issue is addressed in the following components (and later versions):
- crpe32.dll, version 11.0.0.2064, dated 3/28/2006 (commonXIwin_chf.zip)
- crw32.exe, version 11.0.0.2064, dated 3/28/2006 (crXIwin_chf.zip)
BusinessObjects Enterprise XI for Linux
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For BusinessObjects Enterprise XI for Linux, the latest update for this issue is available on the Downloads area of our web site.
This issue is addressed in the following components (and later versions):
- crpe32.rsb, version 11.0.0.187, dated 4/11/2006 (beXIlin_chf.tar.gz)
- libcrpe32.so, version 11.0.0.183, dated 4/11/2006 (beXIlin_chf.tar.gz)
Monthly Hot Fixes and Service Packs
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To determine if this issue is also addressed in a Monthly Hot Fix or Service Pack for your product, search the readme file for the Track ID number (that is, ADAPTXXXXXXXX) in the latest Monthly Hot Fix or Service Pack.
Monthly Hot Fixes readmes and Service Pack readmes are available in the Downloads area of our web site.
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NOTE:
Issues addressed on one operating system platform at the Weekly Hot Fix level may be addressed later on multiple operating system platforms (if applicable) at the Monthly Hot Fix and Service Packs level. For example, an issue only resolved on the Windows platform in a Weekly Hot Fix may be resolved later on UNIX platforms such as IBM AIX and Sun Solaris in future Monthly Hot Fixes or Service Packs for these platforms.
To determine if these issues are resolved in a Monthly Hot Fix or Service Pack on another platform, search for the Track ID number in the readme at the locations indicated above.
See Also
For more information on the issues addressed in the Hot Fix or Service Pack, view the readme PDF or text file included in the ZIP or TAR file.
For more information on the different update types, refer to our Hot Fix and Service Pack FAQ.
Keywords
CHF 567597 Crystal Reports Verify Database Error message , c2019218 , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Bug Filed