Symptom
After exporting a report to PDF, text objects in the PDF cannot be edited using the Touch-Up Tool. Instead, the following error message appears:
"No system font is available".
Cause
The cause of the problem is that fonts in Crystal Reports and their correct names fail to be properly mapped to their Adobe Acrobat counterparts.
The issue has been identified and tracked under ID ADAPT00541381.
Resolution
Hot Fixes or Service Packs address this issue as indicated below. With the update(s), this problem is resolved.
Known limitations: Fonts that do not have an explicit definition (emulated fonts) in Adobe Acrobat may show inconsistent spacing and formatting when edited (for example, fonts like Comic Sans MS, in italics).
Also, Adobe Acrobat will use its own version of the Courier New font when that font is edited.
Unless indicated otherwise, Critical Hot Fix updates from the FTP site have only been tested with English versions of our products.
====================
CAUTION:
Hot Fixes and Service Packs are not designed for OEM versions. Do not apply these updates if you are using an OEM version. To determine if you are using an OEM version, refer to the OEM Product Warning.
====================
Crystal Reports XI Release 2
------------------------
For Crystal Reports XI Release 2, the latest update for this issue is available on the Downloads area of our web site.
This issue is addressed in the following components (and later versions):
- crxf_pdf.dll, version 11.5.6.490, dated 5/8/2006 (boXIr2win_chf.zip)
Crystal Reports XI
--------------------
For Crystal Reports XI, the latest update for this issue is available on the Downloads area of our web site.
This issue is addressed in the following components (and later versions):
- crxf_pdf.dll, version 11.0.0.2083, dated 4/16/2006 (commonXIwin_chf.zip)
Crystal Reports 10
---------------------
For Crystal Reports 10, the latest update for this issue is available on the Downloads area of our web site.
This issue is addressed in the following components (and later versions):
- crxf_pdf.dll, version 10.0.5.604, dated 4/16/2006 (dbex10win_en.zip)
- crxf_pdf_res_en.dll, version 10.0.5.604, dated 4/16/2006 (dbex10win_en.zip)
Crystal Reports 9
--------------------
For Crystal Reports 9, the latest update for this issue is available on the Downloads area of our web site.
This issue is addressed in the following components (and later versions):
- crxf_pdf.dll, version 9.2.1.572, dated 4/21/2006 (cr90dbexwin_en.zip)
Monthly Hot Fixes and Service Packs
------------------------------------------
To determine if this issue is also addressed in a Monthly Hot Fix or Service Pack for your product, search the readme file for the Track ID number (that is, ADAPTXXXXXXXX) in the latest Monthly Hot Fix or Service Pack.
Monthly Hot Fixes readmes and Service Pack readmes are available in the Downloads area of our web site.
====================
NOTE:
Issues addressed on one operating system platform at the Weekly Hot Fix level may be addressed later on multiple operating system platforms (if applicable) at the Monthly Hot Fix and Service Packs level. For example, an issue only resolved on the Windows platform in a Weekly Hot Fix may be resolved later on UNIX platforms such as IBM AIX and Sun Solaris in future Monthly Hot Fixes or Service Packs for these platforms.
To determine if these issues are resolved in a Monthly Hot Fix or Service Pack on another platform, search for the Track ID number in the readme at the locations indicated above.
See Also
For more information on the issues addressed in the Hot Fix or Service Pack, view the readme PDF or text file included in the ZIP or TAR file.
For more information on the different update types, refer to our Hot Fix and Service Pack FAQ.
Keywords
CHF 541381 Crystal Reports Export to PDF format Error message , c2019242 , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Bug Filed