SAP Knowledge Base Article - Public

1220164 - Error: "Failed to open the connection xxx.rpt."

Symptom

After changing the JDBC connection and changing a registry key, when users preview a report, the following error message appears:

"Failed to open the connection xxx.rpt."

 

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NOTE:

 

This problem happens when changing the JDBC connection in the custom logon information in the Central Management Console (CMC), and then setting the following registry key to "Yes":

 

HKEY_LOCAL_MACHINE\Software\Business Objects\Suite 11.5\Crystal Reports\DatabaseOptions\MergeConnectionProperties

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Cause

The issue has been identified and tracked under ID ADAPT00397901.

Resolution

Hot Fixes or Service Packs address this issue as indicated below. With the update(s), this issue is resolved.

Known limitations: This HotFix allows users to change databases, but the database types must be the same. For example, the location of one SQLServer database can only be changed to another SQLServer database. The source class name must use the same name for the destination class.

When setting the location of the database through a URL, the complete URL must be used. This HotFix does not support setting the location by only the server name.

Unless indicated otherwise, Critical Hot Fix updates from the FTP site have only been tested with English versions of our products.

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CAUTION:

Hot Fixes and Service Packs are not designed for OEM versions. Do not apply these updates if you are using an OEM version. To determine if you are using an OEM version, refer to the OEM Product Warning.

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Crystal Reports XI

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For Crystal Reports XI, the latest update for this issue is available on the Downloads area of our web site.

This issue is addressed in the following components (and later versions):

  • crdb_jdbc.dll, version 11.0.0.2049, dated 3/13/2006 (commonXIwin_chf.zip)
  • crpe32.dll, version 11.0.0.2050, dated 3/14/2006 (commonXIwin_chf.zip)

 

Monthly Hot Fixes and Service Packs

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To determine if this issue is also addressed in a Monthly Hot Fix or Service Pack for your product, search the readme file for the Track ID number (that is, ADAPTXXXXXXXX) in the latest Monthly Hot Fix or Service Pack.

Monthly Hot Fixes readmes and Service Pack readmes are available in the Downloads area of our web site.

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NOTE:

Issues addressed on one operating system platform at the Weekly Hot Fix level may be addressed later on multiple operating system platforms (if applicable) at the Monthly Hot Fix and Service Packs level. For example, an issue only resolved on the Windows platform in a Weekly Hot Fix may be resolved later on UNIX platforms such as IBM AIX and Sun Solaris in future Monthly Hot Fixes or Service Packs for these platforms.

To determine if these issues are resolved in a Monthly Hot Fix or Service Pack on another platform, search for the Track ID number in the readme at the locations indicated above.

See Also

For more information on the issues addressed in the Hot Fix or Service Pack, view the readme PDF or text file included in the ZIP or TAR file.

For more information on the different update types, refer to our Hot Fix and Service Pack FAQ.

Keywords

CHF 397901 JDBC ERROR MESSAGE REGISTRY Crystal Reports JDBC Error message , c2019168 , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Bug Filed

Product

SAP Crystal Reports XI ; SAP Crystal Reports XI R2