Symptom
The Printer button is not available on the Page Setup dialog in Crystal Reports XI Release 2 when installed on Windows Vista.
Reproducing the Issue
Steps to Reproduce
- Open a Report in Crystal Reports.
- Go to the 'File' menu and 'Page Setup' in Crystal Reports.
- The 'Printer' button not available.
Environment:
- Crystal Reports XI R2
- Vista operating systems, all editions
Cause
This is the result of a change in functionality with the Vista operating system.
- Microsoft has made a change to the common application programming interface (API) as used by Report Designer Component (RDC) for the Page Setup dialog window.
- It is no longer possible to change printer selection directly through the Page Setup dialog.
- Other applications that also use this API have the same behavior.
- See for example Internet Explorer, Notepad, or any other application.
- See for example Internet Explorer, Notepad, or any other application.
Resolution
With the report open in Crystal Reports
- Select File > Print
- Use keyboard shortcut 'Ctrl-P'
The issue has been identified in Crystal Reports XI Release 2 and logged under Problem Report ID ADAPT01075402
Keywords
printer button Vista Crystal Reports XI R2 Release 2 page setup dialog dialogue ADAPT01075402 01075402 1075402 , KBA , BI , Business intelligence solutions , Problem
Product
SAP Crystal Reports XI R2