Symptom
- The auto-range option in chart expert does not work as expected
- Values on the y-axis are duplicated
Reproducing the Issue
Use a chart which displays 1 decimal place on the y-axis.
- Create a new report with Xtreme Sample Database;
- Add 2 tables "Orders" and "Orders_Detail";
- Create a Formula called "test": {Orders_Detail.Quantity}/10;
- Use Select Expert to create a filter on Orders.Customer ID, "is less than 3";
- Create a Bar chart (insert it in the Report Header), use all default settings, with "On change of" set to "Orders.Customer ID" and "Show value" set to "@test".
- Check the box "don’t summarize" and click OK
Crystal Reports XI Release 2 Service Pack 4 (CR XIR2 SP4)
Cause
This has been identified as a bug with reference ADAPT01103237
Resolution
- Install the Service Pack 5 (SP5)
Workaround:
- From 'Chart Expert'>'Axes' tab, uncheck the 'auto-range' option;
- Select OK and preview the report;
- From 'Chart Expert'>'Axes' tab, check the 'auto-range' option again;
Keywords
KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Bug Filed
Product
SAP Crystal Reports XI R2