Symptom
- Database Connector Error.
- Unable to add Table to a report.
- When adding a Table, it generates an error.
- In Crystal Reports, when creating a report to Remedy via an ODBC Connection, and trying to add a Table, it generates the error: "Database Connector Error"
Environment
- Crystal Reports XI R2
- Remedy
- Remedy ODBC driver version 6.3
Reproducing the Issue
- In Microsoft ODBC Data Source Administrator, ceate an ODBC DSN to Remedy using the ODBC Driver for Remedy version 6.3
- In Crystal Reports, create a new report using an ODBC connection, and select the ODBC DSN to Remedy.
- Enter the Remedy data source credentials.
- Add a Table to the report.
It then generates the error.
Cause
- Remedy ODBC driver issue.
Resolution
- Apply the latest update of the Remedy ODBC driver.
- Important Note: For the latest Remedy ODBC driver, contact your database administrator, or the data source provider.
Keywords
Remedy, Database, Select tables, CR , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem
Product
SAP Crystal Reports XI R2