SAP Knowledge Base Article - Public

1276134 - Error "Failed to open connection" when viewing Crystal Reports in Infoview

Symptom

Error: Failed to open the connection when opening Crystal Report in CMC or Infoview

Reproducing the Issue

Environment:

Crystal Reports 2008

Business Objects XI3

Database: Access

Steps to Reproduce:

1. Create a Crystal Report using Access database.

2. The database is in network drive.

3. Save the report in Enterprise.

4. Open the report in CMC "Error : Failed to open the connection with xxx.rpt"

Cause

Crystal Reports does not recognize database connection from share drive

Resolution

1. Save the database locally on server machine

2. Create a new database on server and link the new database with the database on Network.

Steps to link the database.

1.Create a new test database on server.

2. Go to File --> Get External Data --> Link tables | Select the database on Network Drive.

3. Select all the tables from the database.

4. Save the Database  e.g. Test.mdb.

5. Create an ODBC Connection on server machine, with the same name as on client machine using test.mdb database.

Note: Click on Advanced button, enter the default user id and password for the odbc connection, it is not mandatory to give Login Name and Password, only if the user id and password are given then we need to provide the same user id and password in the CMC database configuration.

6. Create a report using this ODBC connection, and save the report to Enterprise.

Keywords

Failed to open Connection, Crystal Reports, Save to, CMC, Infoview, enterprise. , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , How To

Product

Crystal Reports 2008 V0