Symptom
- Error when connecting to stored procedure
- Report fails with this error: Details: [Database Vendor Code: 30186 ] Failed to retrieve data from the database. Error in File C:\WINDOWS\TEMP\Report Name {GUID}.rpt: Failed to retrieve data from the database. Details: [Database Vendor Code: 30186 ]
Reproducing the Issue
- Crystal Reports XI Release 2
- Refreshing data from an ODBC DSN connecting to a DB2/400 stored procedure.
Cause
Configuration settings in the ODBC DSN do not allow the stored procedure to run.
Resolution
- Close all applications that use the DSN.
- Click the Windows Start button and then click Run. Type "Regedit" and click 'OK'.
- Display all current ODBC DSNs by navigating to HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBC.INI.
- Click the folder with the name of your ODBC DSN.
- Right-click in the right window pane, click 'New' and then click 'String value'.
- Name the new String value "AllowProcCalls".
- Right-click 'AllowProcCalls' and click 'Modify'.
- Assign the 'Value Data' to "1".
- Click 'OK' and then close Registry Editor.
Keywords
KBA , BI , Business intelligence solutions , Problem
Product
Crystal Reports 2008 V0 ; Crystal Reports Server 2008 V1, OEM edition ; SAP Crystal Reports 10.0 ; SAP Crystal Reports 9.0 ; SAP Crystal Reports XI ; SAP Crystal Reports XI R2