SAP Knowledge Base Article - Public

1380443 - Error: "No authentication plugins are installed" while logging to Repository Explorer

Symptom

  • Error : "The secEnterprise DLL could not be found or does not exist" while logging into Repository Explorer through Crystal Reports Developer.
  • Error while saving the report to enterprise from Crystal Reports Developer.

Cause

  • Installation of Crystal Reports developer is corrupted and hence the Auth Plugins are not register under registry\HKEY_LOCAL_MACHINE\SOFTWARE\Business Objects\Suite 11.5\Enterprise\Auth Plugins
  • The secEnterprise DLL is not registered.

Resolution

Try to register the secEnterprise.dll through:

Start>Run>regsvr32 "<installation drive>\Program Files\Business Objects\BusinessObjects Enterprise 11.5\win32_x86\plugins\auth\secEnterprise\

If registering the DLL, does not help then reinstall the Crystal Reports developer.

To reinstall the developer:

  1. Manually uninstall the existing installation using the steps given in Note 1218535
  2. Then install the developer.

See Also

Note 1218535

Keywords

CR, log in error
, KBA , BI-BIP-DEP , Webapp Deployment, Networking, Vulnerabilities, Webservices , Problem

Product

SAP Crystal Reports XI R2