Symptom
- Crystal Reports report with List of values (LOV) based on Business Views takes long time to refresh
- How to enhance the performance
Environment
- BusinessObjects Enterprise XI Release 2 Service Pack 2
- Crystal Reports XI Release 2 Service Pack 2
Cause
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If there is a cache miss within the Cache Server for the prompt page, then the prompt engine is activated and it rebuilds the prompt page by accessing the LOV used on that prompt page.
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LOV are cached separately from the prompt page. The cache timeout value for each LOV object is controlled from the Edit List of Values dialog within the Business Views Manager.
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The default value stored in Oldest on-demand data given to a client (in minutes) is 0.
Resolution
- Set the LOV setting 'Oldest on-demand data given to a client (in seconds)' value to the largest possible value.
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Ensure the server level setting for 'Oldest on-demand data given to a client (in minutes)' is equal to or greater than the largest LOV setting.
- Schedule LOV only when necessary.
- For more information on Performance Tuning read the attached document.
Keywords
Parameter Prompt.slow refresh , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem
Product
SAP Crystal Reports XI R2
Attachments
Dynamic, Cascading Prompts Performance Tuning.pdf |