Symptom
You create a sales order with a service item, or a service order.
The parties for service execution (service performer and service execution team) are not defaulted, but you would like to have an automatic proposal.
Or the system proposes a default party, but you expect another one.
Reproducing the Issue
- Go to the Sales Orders work center.
- Select New Sales Order.
- Enter the account ABC (ABC represents the identification number of the account).
- Enter all relevant data.
- Add service XYZ (XYZ represents the identification number of the service).
No service performer or service execution team is found automatically, or the system proposes a service performer or service execution team which is not expected.
Cause
For each party role in each business document there are some steps to determine a party as proposal.
These steps are executed one after the other, until there is at least one party found.
These steps use master data maintained in this system, either responsibility rules or the organizational setup.
If none of the steps find a suitable org center, nothing is defaulted for this party role.
Service Order
Service Performer
- Evaluate account responsibilities (set in the Account Management work center ) with the party role 'Service Performer - Service'
- Evaluate responsibility 'Resp. to Determine Service Performer - Service Order'
Service Execution Team
- Evaluate responsibility 'Resp. to Determine Service Execution Team - Service Order'
- Take service org center of service performer
- Take single service org center in the system
Sales Order
Service Performer
- Evaluate account responsibilities (set in the Account Management work center) with party role 'Service Performer - Sales Orders'
- Evaluate responsibility 'Resp. to Determine Service Performer - Sales Order'
Service Execution Team
- Evaluate responsibility 'Resp. to Determine Srvc. Execution Team - Sales Order'
- Take service org center of service performer
- Take single service org center in the system
Resolution
If there is only one org center handling service execution, it is sufficient to assign the organizational function 'Customer Service' there.
To distinguish several service teams and service performers, for example by address data or product categories, you can maintain responsibility rules. Org centers require the organizational function 'Customer Service' to become responsible for services.
Where to maintain this master data
The assignment of the organizational functions of org centers is done in the Organizational Management work center, via the 'Edit Org Structures' link.
Responsibilities for org centers are maintained in the Organizational Management work center, Work Distribution view and the Organizational Work Distribution sub view. The responsibilities for service execution are available in 'Service and Support' Business Area.
The account dependent employee responsibilities are maintained directly in the account master data in the Account Management work center, in the Contacts tab, Relationships and Responsibilities sub tab under the Responsibilities section.
Relevant party roles are 'Service Performer - Sales Orders' and 'Service Performer - Service'.
The other responsibilities for employees are maintained in the Organizational Management work center, Work Distribution view and the Employee Work Distribution sub view. The responsibilities for service execution are available in 'Service and Support' Business Area.
Keywords
KBA , AP-SLO , Sales Order Processing , How To