Symptom
The Service Performer determined in the Sales Order is not the one expected.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Sales Orders work center.
- Go to Sales Orders view.
- Edit the Sales Order ABC. (ABC represents the ID of Sales Order)
- Go to View All and Go to the Items tab.
- Select the Service Item, the Service Performer is not the one expected.
Cause
The Service Performer is determined according to the following rules:
- Rule #1 Responsibility for Ship-To:
Direct responsibility to the ship-to party can be define. All direct responsibilities overrule the responsibilities maintained in the Application and User Management work center.
- Rule #2 Determine Responsibilities for Service Performer - Sales Order for Ship-To:
The Responsibility to Determine Service Performer - Sales Order work category is used to determine the Service Performer that is responsible to execute the standardized service products in a Sales Order. It is possible to create responsibility rules for this work category related to the following standard set of parameters derived from the account entered in the sales document: Company, Country, Region, City, ZIP Code.
It is also possible to activate additionally the usage of ABC Classification via fine-tuning. Prerequisites:
- The business option for selling services in sales is activated in scoping.
- The Service Units have been defined in the Organizational Management which are responsible for executing the services sold in a Sales Order.
Resolution
- How to maintain Rule #1 Responsibility for Ship-To:
- Go to Account Management work center.
- Go to Accounts view.
- Select the Ship-To Account and choose Edit -> Contacts.
- On the Contact tab select Relationships and Responsibilities.
- In the Responsibilities section, add a service performer.
- Save.
All direct responsibilities overrule the responsibilities maintained in the Application and User Management work center.
- How to maintain Rule #2 Determine Responsibilities for Service Performer - Sales Order for Ship-To:
- Go to Application and User Management work center.
- Go to Task Distribution and then Employee Work Distribution view.
- Go to Service and Support and Resp. to Determine Service Performer - Sales Order
You can define work distribution rules by selecting the ID of User Responsible and the valid from and to date.
Then you can select the rule details: Company, Country, Region, City, ZIP Code.
Example: Employee E_X (E_X is the ID of the Employee) has to be the Service Performer for all Sales Order with a Ship-To Party with country US.
- Maintain a new rule in Work Distribution for the employee E_X.
- In the rule details choose the Country United State and Save.
- How to define responsibility criteria for the selected responsibility category:
- Go to Business Configuration work center.
- Go to Activity List view.
- Select fine tuning activity > Criteria to Determine Responsibilities for Service Execution - Sales Order.
- Select Criteria to Determine Service Performer - Sales Order.
- How to change the determination logic:
- Go to Business Configuration work center.
- Go to Activity List view.
- Select fine tuning activity and then Involved Parties for Sales Orders.
- Select the party role > Maintain Determination.
You can activate or deactivate determination steps for your party role.
Keywords
Service Performer, Sales Order, Determination, Rule , KBA , AP-SLO-SO , Sales Order , How To