SAP Knowledge Base Article - Public

1447142 - Error 1311 while upgrading to Service Pack 5 of Crystal Report Server Embedded XI Release 2

Symptom

While upgrading from Crystal Report Server Embedded XI Release 2 Service Pack 4 to Service Pack 5, following error is displayed:
Error 1311: Source file not found: C:\Docume~1\[user]\Locals~1\Temp\1\win32\m23.cab. Verify that the file exists and that you can access it.

Environment

  • Crystal Report Server Embedded XI Release 2 Service Pack 4
  • Windows 2003 Server 32 bit

Reproducing the Issue

  1. Install Crystal Report Server Embedded XI Release 2 Service Pack 4 (Full build).
  2. Install Crystal Report Server Embedded XI Release 2 Service Pack 5 (Upgrade). The aforesaid error message gets displayed.

Cause

Registry key setting for "My Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Business Objects\Suite 11.5\Report Application\InstallPath" Server reflects incorrect Path.

Resolution

  1. Uninstall Crystal Report Server Embedded XI R2 SP4 (Full build).
  2. Remove the registry key InstallPath from My Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Business Objects\Suite 11.5\Report Application Server if it still exists post uninstall.
  3. If the <Business Objects install folder> still exists, delete the same.
  4. Restart Server and re-install Crystal Report Server Embedded XI R2 SP4 (Full build).
  5. Proceed with SP5 upgrade.

Keywords

Unable to upgrade to Crystal Reports Server Embedded XI R2 ServicePack 5 , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem

Product

Crystal Reports Server XI R2