Symptom
Crystal Reports Server XI and Crystal Reports Server 2008 are installed on the same machine. After installing SP2 for 2008, the XI server's viewrpt.aspx no longer works. The user is prompted to login even though the enterprise credentials have been passed to viewrpt. Also, if one tries to login with a valid enterprise account, the login fails and the logon form is rendered again.
Environment
Crystal Reports Server XI and Crystal Reports Server 2008 on the same machine.
Reproducing the Issue
Call a report with viewrpt.aspx.
Cause
The SP2 patch for 2008 somehow affected the XI installation.
Resolution
Use the following command:
for %i in (*.dll) do regsvr32 /s %i
Following are the steps to run this command.
1) Launch Command Prompt by clicking on Start | Run - type cmd & click OK.
2) Navigate to “C:\Program Files\Business Objects\BusinessObjects Enterprise 12.0\win32_x86\”
3) Run the command here. This will register all dll files in this folder.
4) Run the command in the "C:\Program Files\Common Files\Business Objects\3.0\bin". It is possible that the command only needs to be run in 3.0 directory.
This will reregister the dlls for the XI installation.
Keywords
side by installation regsvr32.exe viewrpt viewrpt.aspx , KBA , BI-BIP-DEP , Webapp Deployment, Networking, Vulnerabilities, Webservices , Problem