Symptom
The customer return is inconsistent with following error: 'Sales Order Reference with ID ABC-DEF not valid'.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Order work center.
- Select the view Return.
- Show All Return and enter return ID XYZ (XYZ represents the number of the return).
- Press Go button.
- Select the return XYZ and press Edit button.
- Select Items tab.
- Error appears: Sales Order Reference with ID ABC-DEF not valid (ABC-DEF represents the identification of the sales order line item).
Cause
The return is not assigned to the sales order ABC.
Resolution
- Go to the Sales Order work center.
- Select the view Return.
- Show All Return and enter return ID XYZ (XYZ represents the number of the return).
- Press Go button.
- Select the return XYZ and press Edit button.
- Select Items tab.
- Select the line item DEF and press Assign Reference Action button (DEF represents the identification of the sales order line item).
- Assign the Reference Type, Reference ID, Reference Line and press Ok.
- Save the return XYZ.
Keywords
unposted source document, general ledger, 'Referenced customer return not found (Inbound Delivery)', reference, ID, error message, invalid, incorrect, assign reference , KBA , AP-SLO , Sales Order Processing , AP-CRP , Customer Return Processing , How To
Product
SAP Business ByDesign all versions