SAP Knowledge Base Article - Public

1505322 - Customer Return is Inconsistent - Order Reference Not valid

Symptom

The customer return is inconsistent with following error: 'Sales Order Reference with ID ABC-DEF not valid'.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Sales Order work center.
  2. Select the view Return.
  3. Show All Return and enter return ID XYZ (XYZ represents the number of the return).
  4. Press Go button.
  5. Select the return XYZ and press Edit button.
  6. Select Items tab.
  7. Error appears: Sales Order Reference with ID ABC-DEF not valid (ABC-DEF represents the identification of the sales order line item).

Cause

The return is not assigned to the sales order ABC.

Resolution

  1. Go to the Sales Order work center.
  2. Select the view Return.
  3. Show All Return and enter return ID XYZ (XYZ represents the number of the return).
  4. Press Go button.
  5. Select the return XYZ and press Edit button.
  6. Select Items tab.
  7. Select the line item DEF and press Assign Reference Action button (DEF represents the identification of the sales order line item).
  8. Assign the Reference Type, Reference ID, Reference Line and press Ok.
  9. Save the return XYZ.

Keywords

unposted source document, general ledger, 'Referenced customer return not found (Inbound Delivery)', reference, ID, error message, invalid, incorrect, assign reference , KBA , AP-SLO , Sales Order Processing , AP-CRP , Customer Return Processing , How To

Product

SAP Business ByDesign all versions