Symptom
- In Central Configuration Manager (CCM), adding "-port FQDN" to the Central Management Server (CMS) command line, the CMS doesn't start
- Adding -trace, the following output is provided in the cms log file:
[Tue Aug 03 13:02:14 2010] 2584 2580 trace message: A standard version or per-processor license doesn't permit server registration from another machine. [Tue Aug 03 13:02:14 2010] 2584 2580 trace message: [UID=0;USID=0;ID=218] Update object in database failed [Tue Aug 03 13:02:14 2010] 2584 2580 assert failure: (.\NameServer.cpp:329). (ret || CompareStringsNoCase(kind, NativeChar_Services::OCA_APSServer) != 0 : no message). [Tue Aug 03 13:02:14 2010] 2584 2580 (.\nsdll.cpp:143): trace message: NS_TermNameService [Tue Aug 03 13:02:14 2010] 2584 2580 Log: level=0 cat=14 msg=35101 p=The root server reported an error Initialization Failure. |
Environment
- Crystal Reports Server XIr2 (All SP)
- Business Objects Edge XIr2 (To be confirmed)
Reproducing the Issue
- In a Crystal Report Server deployment, stop all the services
- Go to Start > Programs > Crystal Reports Server XI R2 > Central Configuration Manager
- Open the CMS properties
- In the "command line" field, add -port FQDN or -port VirtualHostname
- Try to restart the CMS, it goes in Stopped status after a few seconds.
Cause
Crystal Reports Server and Edge are single box deployments only.
They are meant for small deployments. For large scaling deployment, it is necessary to move to the enterprise licensing model.
Resolution
Use a Business Objects Enterprise license
Keywords
KBA , BI-BIP-DEP , Webapp Deployment, Networking, Vulnerabilities, Webservices , Problem