Symptom
Why are changed master data (such as e.g. the business partner address data, Product Master Data or changes in Org Management) not taken over dynamically by the system:
- in existing sales documents,
- in new sales documents created as a follow-up document,
- in new sales documents created as a copy of an existing document?
Environment
SAP Business ByDesign
Reproducing the Issue
- Existing sales document:
- Go to the Sales Orders work center.
- Under the Common Tasks section, select the New Sales Order hyperlink.
- Enter account XYZ (XYZ represents the identification of an account).
- Account XYZ has the ship-to address ABC (ABC represents the detailed ship-to address of the account).
- Enter all other respective details.
- Save the sales order HIJ (HIJ represents the identification of the sales order you just created).
- Go to the Account Management work center.
- Select the Accounts view.
- Select the account XYZ and click the Edit button and select Addresses from the drop down list.
- Change the ship-to address ABC to EFG (EFG represents the new detailed ship-to address of the account).
- Click the Save button.
- Go to the Sales Orders work center.
- Select the Sales Orders view.
- Open sales order HIJ.
- You can see that account XYZ still has the ship-to address ABC.
- New sales document created as a follow-up document or copy of an existing document:
- Go to the Marketing work center.
- Select the Leads view.
- Click the New button and select the New Leads option.
- Enter account XYZ.
- Enter all other respective details such as Description and Qualification.
- Save the lead KLM (KLM represents the identification of the lead you just created).
- Click the Hand Over button to hand over the lead to New Business.
- Go to the Account Management work center.
- Select the Accounts view.
- Select the account XYZ and click the Edit button and change the name to XYZ-ABC.
- Click the Save button.
- Go to the New Business work center.
- Select the Leads view.
- Select lead KLM.
- Click the Follow-Up button and select the Opportunity option.
- You can see that in the new Opportunity the Account name is displayed as XYZ.
- The changes in the account master data have not been taken over.
Cause
When creating a new document via the Follow-Up or the Copy functionality, the system will copy all details including the master data (Account Master Data, Product Master Data, Pricing Data and Organizational Data) from the corresponding base document.
The change of the master data such as addresses/name etc. is not dynamically updated by the system because in some cases it is necessary to keep the old data for existing sales documents or sales documents which are based on existing sales documents.
Therefore, the change has to be triggered manually in the sales document if required. Due to the same reason also price changes needs also to be updated manually with customer quotes or sales orders.
For the Bill-To Party and the Seller Party address there are scoping questions available to enable the system to redetermine the address from the master data/organizational data:
- Do you want to redetermine the address of the Bill-To Party from the master data at the time of invoice creation?
Instead of defaulting the Bill-To address from the corresponding predecessor document, the system will default the address from the master data at the time of customer invoice and project invoice request creation.
- Do you want to redetermine the address of the Seller Party from the master data at the time of invoice creation? (available with Release 2411)
Instead of defaulting the Seller Party address from the corresponding predecessor document, the system will default the address from the master data at the time of customer invoice creation.
Resolution
This is the standard system behavior.
To trigger the changes in the master data in sales documents you have to remove the master data e.g. the business partner and enter it again in your sales document.
Please note:
- For the bill-to address you have the option to redetermine the address of the Bill-To Party at the time of invoice creation by activating the following scoping question in your project scope in the Business Configuration: Do you want to redetermine the address of the Bill-To party from the master data at the time of invoice creation?
- For Customer Invoices created as a copy removing the master data e.g. the business partner Account and enter it again in the invoice will not trigger the changes in the master data. You will have to perform those changes e.g. Payment Terms manually in the Invoice.
- With Release 2411, for the Seller Party address you have the option to redetermine the address of the Seller Party at the time of invoice creation by activating the following scoping question in your project scope in the Business Configuration: Do you want to redetermine the address of the Seller Party from the master data at the time of invoice creation?
- Go to the Business Configuration work center.
- Select the Implementation Projects view.
- Select your implementation project and click on the Open Project Scope button.
- Navigate to the Questions tab.
- Expand the Path: Sales -> Customer Invoicing -> Miscellaneous Invoicing
- In the Group Miscellaneous Invoicing you can find the questions and can activate them as per your requirement:
Do you want to redetermine the address of the Seller Party from the master data at the time of invoice creation?
Do you want to redetermine the address of the Bill-To Party from the master data at the time of invoice creation?
See Also
For further details please see help center document: Create a Project Invoice Request for a Customer Project.
Keywords
Change Master Data; Copy; Follow-Up; Address; Change; Payment Terms, Update, Master Data, Dynamic, Dynamically, Sales, Sales Document, Seller; Bill-To; Party; Change , KBA , sales order , sales quote , customer invoice , service order , opportunity , project invoice , dynamic , AP-SLO , Sales Order Processing , AP-CI-CI , Customer Invoice , How To