SAP Knowledge Base Article - Public

1512419 - Customer Invoice is not Posting Because of Error Message: 'Referenced item of Sales Order XYZ not found'

Symptom

You are trying to post a Customer Invoice and you are getting the following error message: 'Referenced item of Sales Order XYZ not found'.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the General Ledger work center.
  2. Go to the Closing Cockpit view.
  3. Go to the Source Documents sub view.
  4. Select the source document of your customer invoice DEF (DEF represents the customer invoice ID).
  5. You will see the task 'Referenced item of Sales Order XYZ (XYZ represents the sales order ID) not found'.

Now, you will check the Sales Order in question:

  1. Go to the Sales Order work center.
  2. Go to the Sales Order view.
  3. Show All Orders.
  4. Select your Sales Order XYZ.
  5. You will find that the sales order is having the status Completed.

Cause

Your sales order is not posted successfully in accounting. One more Business Transaction task exists for your sales order. You can see the task by doing the below steps:

  1. Go to the General Ledger work center.
  2. Go to the Closing Cockpit view.
  3. Go to the Source Documents sub view.
  4. Select Unposted Source Documents.
  5. Select the source document of your sales order XYZ.
  6. Select the View Business Transaction button.

You will see the other Business Transaction task there. For example the task can be 'Period XXX in fiscal year YYYY is closed for closing step Operational postings'.

If there is a Process Communication Error in the Sales Order you can find the actual error message as follows:

  1. Go to the Application and User Management work center.
  2. Go to the Process Communication Errors view.
  3. Select Open Errors with Cases.
  4. In the Column Sending Document ID enter the filter CreateAccountingNotification.
  5. Select the Sales Order XYZ.

You will see the error that is causing the process communication error. For example the task can be ‘Service Execution Confimation not possible; posting on DD.MM.YYYY blocked in company A’ (A represents the ID of the Company)’.

Resolution

You need to resolve the Business Transaction tasks first. Once this is done, you need to repost the source document of your sales order. After that repost the source document of your customer invoice. Your customer invoice will be posted successfully in accounting.

If there was a process communication error in the Sales Order, you can trigger the process message after you corrected the error (in our example, open the posting period for postings on the DD.MM.YYYY for company A and Business Process Group as 08 - Service Execution Confimation) using the following steps:

  1. Go to the Application and User Management work center.
  2. Go to the Business Document Differences view.
  3. Select the Sales Order XYZ.
  4. Click on the Start Document Synchronization button.

Your Sales Order will be posted successfully in accounting. 

Steps to repost the source document are below:

  1. Go to the General Ledger work center.
  2. Go to the Closing Cockpit view.
  3. Go to the Source Documents sub view.
  4. Select Unposted Source Documents.
  5. Select the source document of your customer invoice DEF.
  6. Select the button Action -> View Business Transaction button.
  7. Select the Post button.

This will post your source document successfully in accounting.

Keywords

Customer Invoice; Referenced item of Sales Order XYZ not found; Source Document; Unpost Source Document; Sales Order; Blocked; Service Execution Confimation, Service Execution Confirmation,  , KBA , AP-SLO , Sales Order Processing , SRD-FIN-GL , General Ledger , How To

Product

SAP Business ByDesign all versions