Symptom
If you have a contact which is assigned to two Business partner, one is locked and other is active. In contact the field Department from business Card is empty but this data is maintained in the active Business partner.
Reproducing the Issue
Steps to check in Contact
- Go to Business Partner Data workcenter.
- Select Contacts view.
- Search for the contact and select Edit button.
- In General tab, under section Business Address, the field Department From Business Card is empty.
Where you could find some of the datas has been taken from the locked business partner.
Steps to check in active Business partner
- Go to Business Partner Data workcenter.
- Select Business partner view.
- Search for the Business partner and select Edit button.
- Go to contacts tab.
Where the data is maintained in the field Department From Business Card.
Cause
The functionality is working as designed.
The system is taking both the Business Partner IDs as seperate Business Partners.So if in one BP account, if the department details are not maintained then it will not be shown in contacts.This is inline with the concept that a person can be a contact person for multiple accounts (This is a scenario in SME)
Resolution
You can perform some changes in the contact maintenance for a correct view. Steps are as follows,
- Go to Business Partner Data workcenter.
- Select Contacts view.
- Search for the contact and select Edit button.
- Select View All button.
- In General tab, under section Business partner, If the locked BP ID is maintained then you cchange it to the active BP ID.
- Go to Relationships tab and you can remove the relationship with the locked account.
Keywords
KBA , SRD-MD-BP , Business Partner , Product Enhancement