Symptom
Scales setting of chart on x-axis are reverted to default after color highlight is added or removed.
Environment
- BusinessObjects Enterprise XI 3.1 SP2
- Crystal Reports 2008 SP2
Reproducing the Issue
- Open CR designer->File->New->Blank Report.
- From the Database Expert Panel->Create New Connection->ODBC(RDO)->Choose Xtreme Sample Database->Tables->Select 'Orders' table and drag it to the Selected Tables panel.
- In the Design area->Create two report headers(report header a and report header b)->select Chart from the Insert tab and place it in the report header a.
- In the chart expert window->Go to Data tab->From the Available Fields section->
-select 'Order Date' and drag it to the On Change Of section.Change the sort order of the Order Date field to Ascending Order and 'For each month'.
-select 'Order Amount' and drag it to the Show Values section. - In the chart expert window->Go to Type tab->Choose the chart type as Numeric Axis->Date axis bar chart.
- In the Design section->click on the chart and select the legend->Right click on the legend->Format legend->Layout->Uncheck the option 'Show Legend'.
- Go to Report->select expert->record->choose Order Date->apply the filter to'is greater than or equal to'and select any date from the drop down.
- On the chart, the date on the x-axis is displayed as the default system date format.Change it to MMM-YY format by (Right click on any date field->Go to 'Group X Axis Options'->Scales->Change the Minimum/Maximum Date and Major/Minor unit.
- Similarly,Insert another chart in the report header b and perform the steps 4 to 8 again.
- Now in the second chart->Go to chart expert->Color Highlight->Apply the condition(is 'greater than or equal to' and 'less than or equal to') on the 'Sum of Orders.Order Amount' field.Mention a certain amount and select appropriate color format for both the conditions.
- For the second chart,in the Preview section of the report,we will observe that the scales settings on the x-axis is reverted back to the default value.
Cause
The issue has been identified and logged under ADAPT01475369.
Resolution
This issue is scheduled to be addressed in a future Fix Pack or Service Pack.
Keywords
Bar charts,Date on X-axis,Scales settings on X-axis,Crystal Report bar chart.
, KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem
Product
SAP Crystal Reports all versions
SAP Knowledge Base Article - Public