Symptom
- Fails when selecting an SAP BW BEx Query in Crystal Reports.
- When attempting to connect to an SAP BW BEx Query from Crystal Reports, it fails with the error:
"COM exception caught in CExtToolBar::GenerateTemplateHelper(). HR = 0x80010105"
Environment
- SAP Crystal Reports 2016
- SAP Crystal Reports 2020
- SAP Crystal Reports 2025
Reproducing the Issue
- Open Crystal Reports.
- In the SAP Toolbar, click the button 'Create new report from a query'.
- Connect to the BW system.
- Select a BW query and click OK.
- The error message will be displayed.
Cause
- The 'req. status' value for the BEx Query under the RSRT transaction code is set too high, and does not allow to use the BEx Query.
Resolution
- The "request status" setting in transaction RSRT needs to be adjusted.
- Launch the SAP GUI and enter transaction code: RSRT
- In the 'Query' text box, type in or search for the query name.
- Click on the 'Properties' tab.
- Modify the 'Req. Status' value to be lower.
NOTE:
The request status can be set to different values, which will affect whether the yellow request (open request created by planning function) will read or not during the query run.
For example:
0 - will only read all the green requests
9 - will including red and yellow requests
Keywords
RSRT, BEx, CExtToolBar, GenerateTemplateHelper, HR = 0x80010105, SAPIK , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem
Product
SAP Crystal Reports 2016 ; SAP Crystal Reports 2020 ; SAP Crystal Reports 2025