Symptom
You, as a time administrator, find that the Balance Days of Time Account Quota in employee's time file still shows remaining days instead of zero although you have set a rule in Fine-tune activity to change the remaining balance to zero at the end of the fiscal year (e.g. Anually, April 1).
Reproducing the Issue
- Go to the Time Administration work center.
- Select the Employees view.
- Select the employee and choose the Edit button.
- Go to the Time Accounts Balances tab.
- In the Time Accounts section, you can see the Balance as X days.
Cause
This is because that no time valuation correction run has been triggered yet.
If an employee's time administration data are changed, all results are automatically updated. However, if fine tuning settings are changed, which potentially concern many employees, no automatic update of employee data takes place. Future results are updated in the next day closure run, but past data need to be corrected by a time valuation correction run manually.
Resolution
Correction run for an employees:
- Go to the Time Administration work center.
- Select the Regular Tasks view.
- Select the Run Day Closure for One Employee link under Time Valuations.
- Select the employee and you choose the required action based on your business requirement.
Correction run for many or all employees:
- Go to the Time Administration work center.
- Select the Regular Tasks view.
- Select the Administer Day Closure Runs link under Time Valuations.
- Select New button and choose the Day Closure Run option.
- Enter an ID (for your reference), Description and Correction Start Date.
- Choose Save and Close button.
- Note that you can set the Selection Criteria to select the employees this action needs to perform on based on your business needs.
Keywords
Balance Days , Balance Days Set to Zero, Time Account Balance days , KBA , SRD-HR-TLM , Time and Labour Management , Product Enhancement