SAP Knowledge Base Article - Public

1584460 - Exception in Supplier Invoice: The receipt document is missing or invalid.

Symptom

There is an exception in Supplier Invoice because of missing receipt or return document.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to Supplier Invoicing work center.
  2. Go to Invoices and Credit Memos view.
  3. Search for ABC (ABC is the invoice's ID).
  4. Navigate to Exceptios tab. 

There is an exception with the error message: "The receipt document is missing or invalid."

Cause

Cause 1: There is already an Invoice created for all the line items (for entire quantity) of purchase order with respect to Goods and Services Receipt. So when the user tries to create a new Supplier Invoice for the same items of the Purchase Order (for extra quantity), for which there is no delivery done, system raises the exception.

Cause 2: The wrong quantity is being used in the current Invoice or in an older Invoice for the same Purchase Order. For example, it is being used 'days' instead of 'working days'. In that case 24 hours a day instead of 8 hours a day are invoiced against the purchase order. Consequently, less time entries are left for invoicing and the error is thrown. Note that the total price on the Invoice remains the same which makes it hard to detect the wrong input.

The steps to check this are shown below:

  1. Go to Purchase Requests and Orders work center.
  2. Go to Purchase Orders view. 
  3. Search for DEF (DEF is the Order's ID). 
  4. Click in Edit button. 
  5. Navigate to Items tab. 
  6. Check the quantity and unit of measure of the corresponding invoice's item. 

Cause 3: The Purchase Order's Delivery status was Manually Finished. Hence system won't generate any Receipt document and the Exception is triggered.

Cause 4: This is only for Invoices created for migrated Purchase Orders. The cause is that there is no delivered quantity for the migrated Purchase Order.

Cause 5: This is for an intercompany Supplier Invoice. There is a miscommunication happened in the system, making the Invoice has no receipt document, even though it was coming from a valid inbound delivery.

Cause 6: The Supplier Invoice was created before the Inbound Delivery. As a result, the references were not updated in the cost distribution of the Invoice and hence created Inbound Delivery is not available in the Supplier Invoice.

Resolution

Resolution 1: Please follow the steps below to accept the exception:

  1. Go to Supplier Invoicing work center.
  2. Go to Invoices and Credit Memos view.
  3. Search for ABC.
  4. Navigate to Exceptios tab. 
  5. Click in Allow Post without Receipt Document button. 

Resolution 2: Correct the quantity in the invoice.

Resolution 3: Please follow the steps in Resolution 1.

Resolution 4: In order for migrated Purchase Order has follow-up delivery document, the user needs to either create Delivery documents in the system againt the Purchase Order or enter the delivered quantity (under Document Flow tab) in Purchase Order migration template. Then system will show the delivery document in purchase order document flow as you expected.

Please note that, in order for the migrated delivery document posted in Source Document side, you need to migrate open Goods Receipts into the system with reference to migrated Purchase Order. Please check details in Help Document: Quick Guide for Invoice Entry - Section: Migrate Open Goods Receipt.

Resolution 5: The user can correct the miscommunication by performing a dummy change in the Invoice by doing following below steps:

  1. Open Supplier Invoice ABC. 
  2. Navigate to Items tab. 
  3. Select the item that is in exception. 
  4. Navigate to Basic Data sub tab. 
  5. Scroll down to section “Buyer References”. There is no field “Goods Receipt ID” below the field “Order Migrated Code”, it should be there with the receipt document.
  6. Change the field ‘Order Migrated Code’ from blank to ‘Not Migrated’ (don't save yet!). 
  7. Erase the ‘Not Migrated’ from the field leaving it blank again.
  8. Click anywhere in the screen. 
  9. Then, the field “Goods Receipt ID” will show up with the related document (now save it).

Resolution 6: The user can update the Inbound Delivery references by following the below steps.

  1. Open supplier invoice ABC. 
  2. Navigate to Items tab. 
  3. For the item that is in exception, remove the Order ID and Order Item reference. 
  4. Reenter the Order ID and Order Item reference. 
  5. Now the document should have status 'Ready for Posting'. 

See Also

Keywords

Supplier Invoice; Exception; Missing Receipt or Return Document; The receipt document is missing or invalid; Migrated Purchase Order , KBA , AP-SIP , Supplier Invoice Processing , How To

Product

SAP Business ByDesign all versions