Symptom
You are creating a new contract for the supplier and adding price scales for service/material in ascending order. For example: A consultant worked more than the agreed hours and you want to maintain a higher price per hour for the additional time. However the system shows an error message: Scale amounts are not in descending order.
Reproducing the Issue
- Go to the Sourcing and Contracting work center
- Go to the Contracts View
- Select the relevant Contract and choose Edit
- Go to the Items tab and select Line Item
- Go to the sub tab Prices
- Select Add Row under table Price Scales of Contract Price
- Enter the Price Scale in ascending order and select the button Check
Cause
Ascending price scales are not suitable to consider higher prices for overtime – even in the simple case where a user enters times per day in time and labor management.
For example: Let’s assume there is a surcharge, if you work more than 8 hrs/day. Assume you specify 10 USD from Zero hours and 12 USD from 8 hrs/day. If you work for 9 hrs/day, you should get 8*10 USD + 1*12 USD = 92 USD. But the system would calculate 9*12 USD = 108 USD. As the issue will be more complex for many use cases, it is not recommended to remove the check for descending price scales.
Resolution
This is the correct system behavior and system is working as designed.
Keywords
KBA , scale amounts , contract price , AP-PCP , Purchasing Contract Processing , How To