Symptom
When you try to assign an Extension Field to a particular report, system throws below warning message:
Retrieving reports and Data Sources is failed. User XYZ not authorized to extend analytical reports
Reproducing the Issue
This issue will occur in the Adaptation mode of any work center, view or any screen. For this document, let assume the issue occurs while adding an extension field to a report associated with Accounts.
- Go to Business Partner Data work center.
- Select Accounts view.
- Select All Accounts in Show field and select Go button.
- Select Adapt and choose Edit Screen option.
- Select Extension Fields pane in the side bar.
- At the bottom of the Field Properties, select Further Usage link.
- A window opens up with the above warning message.
Cause
User has no authorization for Business Analytics work center.
Resolution
To add an extension field to a report user requires authorizations provided by the Business Analytics work center.
- Go to Application and User Management work center.
- Select User and Access Management view.
- Select Business Users sub view.
- Highlight the user, Select Edit button and choose Access rights option.
- Go to Work Center and Work Center Assignment tab.
- Highlight Business Analytics work center and select Assigned to User check box.
- Select Save and Close button and accept the warning.
- Log off and login again, so the changes will reflect for the user.
Keywords
KBA , retrieving reports and data sources , extension field , SRD-CC-IAM , Identity & Access Management , Product Enhancement