Symptom
- Crystal Reports stops working.
- When connecting to Progress OpenEdge, and adding 2 Tables, Crystal Reports 2011 crash.
Environment
- Crystal Reports 2011 - Support Pack 01
- Progress OpenEdge 10.2B
- Progress OpenEdge 10.2B ODBC driver
Reproducing the Issue
- In Crystal Reports, create a new report.
- From Database Expert, create an ODBC connection
- Log into OpenEdge 10.2B database
- Select at least 2 tables
Cause
- The database Progress OpenEdge 10.2B is unsupported by Crystal Reports 2011 - SP01
Resolution
- Review the supported platforms document for Crystal Reports 2011, and connect to a database supported by Crystal Reports 2011
- Review the following SAP Knowledge Base Article:
2120365 - SAP Crystal Reports 2013 crashes on adding a second table to Progress OpenEdge connection
Keywords
CR , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem
Product
SAP Crystal Reports 2011