Symptom
You, as a personnel administrator, have added an extension field in employee's Personnel File screen by Adapt. But you find the field is read-only when editing the employee's personnel file.
Reproducing the Issue
- Go to the Personnel Administration work center.
- Select the Employees view.
- Select an employee and click the Edit button.
- Select the Adapt option in the top-left corner of the screen and choose Enter Adaptation Mode.
- Select Adapt and choose Edit Screen.
- In the right pane, Select Extension Fields. You can add customized field in different sections.
- Make the added field visible and select the Publish button.
Cause
The cause for the issue is that you add the extension field in the General tab of the personnel file.
Resolution
The system works as designed.
In the General tab, all information is read-only. You cannot edit anything here. All information available in the General tab can be edited in one of the other tabs, for example, in Biographical Data subtab under Personal Data tab.
So if you want to edit the extension field, it should be placed in other tabs of the personnel file than the General tab.
Keywords
KBA , SRD-HR-PAD , Personnel Administration , Product Enhancement