Symptom
- Error: Failed to Open the connection Details:Unexpected Error
- When attempting to create a new report or refresh a report based off Salesforce.com in Crystal Reports 2011 Support Pack 02, it fails with the error:
"Failed to Open the connection
Details:Unexpected Error"
Environment
- SAP Crystal Reports 2011 - Support Pack 02
- Salesforce.com
Reproducing the Issue
- Open Crystal Reports 2011
- Create a new connection, and select Salesforce
- Enter the Salesforce.com user name and password, and click "OK"
It will fail with the error: "Failed to Open the connection Details:Unexpected Error"
Cause
- The incorrect files for the Salesforce.com connectivity was delivered in Support Pack 2 of Crystal Reports 2011.
- This issue has been reproduced at SAP, and tracked under ADAPT01587601
Resolution
- The issue has been resolved in the following product update of Crystal Reports 2011:
- Support Pack 02 - Patch 9
- Support Pack 03 - Patch 4
- Support Pack 04
Keywords
CR, SFDC, SForce , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Bug Filed
Product
SAP Crystal Reports 2011, feature pack 03