Symptom
When the goods returned by customer arrive at the warehouse, you create a customer return notification, and then process the inbound delivery. After that you find out the related warehouse confirmation document is not posted to accounting due to the error message: Referenced customer return not found (Inbound Delivery ABC).
ABC means the Inbound Delivery ID.
Environment
SAP Business ByDesign
Reproducing the Issue
- In the General Ledger work center, choose the Closing Cockpit view.
- Select the Source Documents subview.
- Show Not Posted Source Documents.
- You can find there is a source document XYZ with the Source Document Type being 119 - Warehouse Confirmation
- Choose View Business Transaction, the error message is Referenced Customer Return Not Found (Inbound Delivery ABC).
or
- In the General Ledger work center, choose the Work view.
- You will see an open task with the Subject being Referenced Customer Return Not Found (Inbound Delivery ABC) or Referenced Customer Return Not Found.
- Check the description of Referenced Customer Return Not Found (Inbound Delivery ABC), you can see: In the CRM Work Center, find the relevant customer return by searching via the inbound delivery reference give in the short text of this task. The inconsistency of the customer return needs to be resolved. Financial Accounting will then get informed and the goods receipt will be posted automatically. This task will then be completed automatically.
Cause
The customer return is not successfully sent to accounting due the following possible reasons:
- Item XX: Mandatory List Price missing
- Item XX: Customer invoice reference with ID DEF not valid; Reference with ID DEF and type customer invoice is not valid; Reference document missing for customer return HIJ
- Tax Calculation failed
- For the specified product and customer, the sales organization and distribution channel must match. Check the master data.
Resolution
In order to successfully post the warehouse confirmation document, first of all, follow the steps below to check the error message in the related customer return:
- Go to the Sales Order work center, and then choose the Returns view.
- Show All Returns, and then choose Advanced Search.
- In the Reference ID field, enter the inbound delivery ID ABC, and then choose Go.
- If there are no error messages in the customer return, you need to create an case to SAP to look at the issue in the backend.
- Otherwise, you might see the following error messages:
- Error message: Item XX: Mandatory List Price missing, use KBA 1936639 - The Error Message "Mandatory List Price missing for the price calculation" is Triggered in a Customer Return .
- Error message: Item XX: Customer invoice reference with ID DEF not valid; Reference with ID DEF and type customer invoice is not valid; Reference document missing for customer return HIJ, use KBA 1913150 - Unassigned Task has been Created for the Customer Return as well as 1818008 - How to Create a Customer Return without a Reference
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Error message: For the specified product and customer, the sales organization and distribution channel must match. Check the master data. For the item with this error message, check the master data of the related product:
- Go to the Product Data work center, choose the Materials view.
- Select and edit the related product of the erroneous item.
- You can see the maintained Distribution Chains.
- Make sure the combination of the sales organization and the distribution channel in the customer return is maintained here.
After you fix all the issues in the customer return, choose Save. Then you can re-post the warehouse confirmation document XYZ:
- In the General Ledger work center, choose the Closing Cockpit view.
- Select the Source Documents subview.
- Show Not Posted Source Documents.
- You can find there is a source document XYZ with the Source Document Type being 119 - Warehouse Confirmation.
- Choose View Business Transaction, and then choose Post.
- If the system gives you another error message saying the fiscal period is closed, you can try to post to another period, or re-open the closed period in order to post the document.
So far, the warehouse confirmation document can be posted; however, the status of the customer return might still be In Process. Because just fixing the issue in customer return and saving it cannot set the customer return to Completed if the customer return is released with a credit memo, and the credit memo is not posted yet.
You can then follow the steps below to set the customer return to Completed:
- Go to the Customer Invoicing work center, and select the Items to be Invoiced view.
- Select the customer return, and then choose the Follow up button.
- Create a credit memo, and on the new screen you can release the credit memo. This action automatically changes the status of the customer return to Completed.
If none of the above solutions can help you solve the issue, please create an case to report the issue.
Keywords
warehouse confirmation; customer return; unposted source document , KBA , warehouse confirmation , tax calculation failed , referenced customer return not found , SRD-FIN-ACC , Financial Accounting , How To