Symptom
- Error "Error "General Server Error: null" when running a dashboard with Xcelsius servers"
- Xcelsius dashboard is based on Query as a Web Service (QaaWS)
- The "Web Services URL" property of the QaaWS connection is changed to "/dswsbobje/qaawsservices/queryasaservice"
- Xcelsius Cache/ Processing servers activated
Environment
- Xcelsius 2008 SP3+
Reproducing the Issue
- Create an Xcelsius dashboard with QaaWS connection
- Modify the connection and change the "Web Services URL" to "/dswsbobje/qaawsservices/queryasaservice"
- Publish it to BusinessObjects Enterprise Repository
- Activate Xcelsius servers (KB 1482395)
- Logon to InfoView and navigate to the dashboard
- Open the Xcelsius dashoard. "General Server Error: null" error pop ups
Cause
- Xcelsius servers need the CUID parameter in the Web Services URL
Resolution
- Modify the QaaWS connection in the dashboard to include the CUID parameter
- The CUID might be observed in Central Management Console (CMC) on the properties of the Query as a Web Service object (CMC - QaaWS - <name of the query>)
The URL should be similar to:
/dswsbobje/qaawsservices/queryasaservice?&cuid=Ad.Sg1mqTGNBmThcA3aSoH0
Keywords
xclesius, general server error, qaaws , KBA , BI-RA-XL , Obsolete: BusinessObjects Dashboards and Presentation Design , Problem
Product
SAP BusinessObjects Xcelsius Enterprise 2008