Symptom
You execute a payment and you receive below error messages:
Technical error in payment authorization; report a case.
Authorization failed.
Save failed; refresh list to perform further actions.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Receivables work center.
- Go to the Automatic Payments view.
- Select the credit card payment which is in status In Preparation.
- Perform the action Execute Payment.
You get the error message:
Technical error in payment authorization; report a case.
Authorization failed.
Save failed; refresh list to perform further actions.
Cause
This is the problem with the M-User certificate validation on the service provider side.
Resolution
Contact the Payment Service Provider informing the details of the M-User Certification and the Payment Reference ID
I. Download the M-User Certificate
- Go to the Application and User Management work center.
- Go to the Input and Output Management view.
- Go to the Communication Arrangements subview.
- Select the Communication Scenario (for example: Computop).
- Click the Communication Scenario Hyperlink.
- Perform the action Download Certificate to download the certificate to your local system.
- Save the file with extension <.cer>.
II. Get the Provider Reference
- Go to the Receivables work center.
- Go to the Automatic Payments view.
- Select the Payment which is in status In preparation.
- View the Payment and navigate to the Document Flow.
- Get the customer invoice from the document flow.
- Go to the Customer Invoicing work center.
- Go to the Invoice Documents view.
- Select the Invoice and perform the action Edit.
- In General tab under Payment click the hyperlink Authorized for Authorization Status.
- From the opened screen, get the Provider Reference ID from the field Provider Reference.
Keywords
Credit card, Payment, Computop, Customer Account, Authorization, Report a case. , KBA , credit card , authorization failed , execute payment , AP-PRO , Project Processing , How To