Symptom
When Executing Payment you get the error message technical error in payment authorization, report an case; Authorization failed; Save failed; refresh list to perform further actions
Environment
Business ByDesign
Reproducing the Issue
- Go to Receivables work center.
- Go to Automatic Payments view.
- Select the credit card payment which is in status In Preparation and Perform the action Execute Payment.
- You get the error message technical error in payment authorization, report an case; Authorization failed; Save failed; refresh list to perform further actions.
Cause
This is the problem with the M-User Certificate validation on the Service provider side.
Resolution
Contact the Payment Service Provider informing the details of the M-User Certification and the Payment Reference ID
I. Download the M-User Certificate
- Go to Application and User Management work center.
- Go to Input and Output Management view.
- Go to Communication Arrangements sub view.
- Select the Service Provider and click on the Service provider Hyperlink.
- Perform the action Download Certificate to download the certificate to your local system.
- Save the file with extension <.cer>.
II. Get the Provider Reference
- Go to the Receivables work center.
- Go to Automatic Payments view.
- Select the Payment which is in status In preparation.
- View the Payment and navigate to the Document Flow.
- Get the customer invoice from the document flow.
- Go to Customer Invoicing work center.
- Go to Invoice Documents view.
- Select the Invoice and perform the action Edit.
- In General Tab under Payment click on the hyperlink Authorized for Authorization Status.
- From the pop up screen get the Provider Reference ID from the field Provider Reference.
Keywords
KBA , credit card , authorization failed , execute payment , AP-PRO , Project Processing , How To
Product
SAP Business ByDesign all versions