SAP Knowledge Base Article - Public

1720573 - Is it Possible to Extend Service Agent ID Field to a Report or Another Screen?

Symptom

You have a requirement to extend the fields like Service Agent ID, First name and Last name to another screen or report.

Reproducing the Issue

  1. Go to Business Partner Data work center.
  2. Select New Service Agent from Common Tasks.
  3. Select Adapt and choose Adaptation Mode.
  4. Again select Adapt and choose Edit Screen option.
  5. Select Extension Field in the Side Bar.

There is no option for extending Service Agent ID field.

Cause

The system works as designed.

Resolution

It is not possible to extend a system defined field to another screen or report. You can only extend an Extension Field created for a screen to another screen.

If you want to have a Service Agent ID field in a screen, then you can create the extension field in that screen.

Keywords

KBA , AP-BP-BPT , Business Partner Template , Product Enhancement

Product

SAP BUSINESS BYDESIGN 1708 ; SAP Business ByDesign 1711