SAP Knowledge Base Article - Public

1730627 - Error Occurs While Creating Service Levels: "Enter type of service, duration, or priority"

Symptom

The following error occurs when creating a Service Level: Enter type of service, duration, or priority

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Service Entitlements work center.
  2. Go to the the Service Level view.
  3. Select the New Service Level.
  4. Go to the Reaction Times tab and maintain a Milestone e.g. Milestone Due Date for Initial Response.
  5. In the Details for Milestone click on Add Row.
  6. Enter a Type of Service e.g.  Service Order - Initial Response, a Priority e.g. Immediate and a Net Labor Time e.g. 1 Hour(s).
  7. Click on the Save button.
  8. The following error occurs:
    Save Failed.
    Enter type of service, duration, or priority.

Cause

You only maintained one Priority for the Type of Service.

You must add a separate row for each priority and for each type of service which you select. For example if you have one types of service and four priorities, you should create a total of 4 rows.

Resolution

  1. Go to the Service Entitlements work center.
  2. Go to the Service Level view.
  3. Select New Service Level.
  4. Go to the Reaction Times tab and maintain a Milestone e.g. Milestone Due Date for Initial Response.
  5. Enter a Type of Service e.g.  Service Order - Initial Response, a Priority e.g. Immediate and a Net Labor Time e.g. 1 Hour(s).
  6. Repeat this for all priorities Immediate, Urgent, Normal and Low.
  7. Click on the Save button.

The Service Level will be saved successfully.

Keywords

Service Level; Error; CL_A1SCRM_SLO_MSG; 22 , KBA , SRD-CRM-SEE , Service Entitlements , How To

Product

SAP BUSINESS BYDESIGN 1708 ; SAP Business ByDesign 1302 ; SAP Business ByDesign 1305 ; SAP Business ByDesign 1308 ; SAP Business ByDesign feature pack 3.0 ; SAP Business ByDesign feature pack 4.0