Symptom
The Customer Part Number is not displayed in the product description of the Form
Reproducing the Issue
- Go to Sales Orders workcenter.
- Go to the Sales Orders view.
- Create a New Sales Order from Common Tasks.
- Enter all the mandatory fields.
- Select View All button and go to the Items tab.
- Add the product ABC in the Items table (ABC represents the ID of the product).
After clicking the Preview button, the product description does not display the Customer Part Number.
Cause
The product description field in the sales order shows the combination of Product ID and the Description maintained in the product master data, it does not show the Customer Part Number automatically.
This is the expected behavior of the SAP Business By Design system.
Resolution
Follow the steps below to change the description field for the product:
1. Go to the Product and Service Portfolio work center.
2. Go to the Products view.
3. Show All Products and Find ABC (ABC represents the ID of the product).
4. Edit the product and select the View All button.
5. Go the Sales tab and select the Customer Part Number subtab.
6. Add the Customer Part Number manually.
Now the Customer Part Number will appear if you add product ABC in the sales order preview.
Keywords
KBA , customer part number , SRD-SRM-PRP , Product Portfolio , How To