Symptom
You are creating a new Sales Order, and in the Sales Order the system has determined the Service Performer ABC (ABC represent the Service Performer ID), but you expected the Service Performer XYZ (XYZ reprsents the Service Performer ID), and now you want to know how the system determines the Service Performer in your Sales Order.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Order work center.
- Go to the Common Tasks view.
- Select New Sales Order.
- Enter the Account ACC (ACC represents the Account ID).
- Go to View All.
- Go to the Involved Tab.
- You can see that the Service Performer ABC is determined automatically instead of the Service Performer XYZ.
Cause
In the current release, the system will now determine the Service Performer according to the priority of the rule. Meaning that a responsibility with “country = US” has an higher priority than “country = ALL”.
Additionally, the system will do a sort on the agent internal UUID (the internal UUID is the identifier from the backend and not visible in the User Interface) and delete duplicate entries.
Pre-requisite: You have maintained the Work Distribution Service Performer for Sale Order and Contracts. This rule can be maintained in the following path:
- Go to the Organizational Management work center.
- Go to the Employee Work Distribution.
- Select the Rule Service Performer for Sale Order and Contracts
Resolution
This is the normal system behavior for the current release.
Keywords
Service Performer, Sales Order, Determination , KBA , SRD-MD-BP , Business Partner , How To