SAP Knowledge Base Article - Public

1747261 - Service Date on a Previewed Purchase Order Differs from the Actual Date

Symptom

Date for the service period on a previewed Purchase Order differs from the actual date on the Purchase Order.

Reproducing the Issue

  1. Go to the Purchase Requests and Orders work center.
  2. Select the Purchase Orders view.
  3. Search for, select and open the Purchase Order.
  4. Select the Items tab and the relevant Service item.
  5. Verify that the Service Period's To and From dates are, e.g., 02/01/2012 00:00.
  6. Click on Preview > PO.
  7. Verify that the Service Period date is from 01/01/2012 to 02/01/2012 instead of just 02/01/2012.

Cause

The discrepancy between the dates on the Purchase Order and on its Preview occurs due to the fact that the start and end times for the service are both 00:00.

Resolution

Change the Service Period To time to a different value from 00:00. If a service spans the whole day, you can set this time to 23:59, for example. Afterwards, click on Send Update to save the changes.

Keywords

KBA , purchase order , AP-POP-PO , Purchase Order , How To

Product

SAP Business ByDesign all versions